CovidCheck.lu Application

The Luxembourg Government provides an application to verify the authenticity and validity of certificates - CovidCheck.lu (EU Digital COVID Certificate – EU DCC).

The app can be installed for free via the Apple App Store or the Google Play Store. It can be installed on a smartphone or tablet.

The CovidCheck.lu mobile application and the validity of certificates

CovidCheck.lu is the Luxembourg application used to verify the authenticity of a CovidCheck certificate (EU Digital COVID Certificate - EU DCC) and the validity according to the rules applicable in the Grand Duchy. It also allows you to check the validity of your certificate against the rules of other countries adhering to the European system. 

It can be used to verify a certificate on paper or a digital copy (e.g. PDF)

A certificate is authentic when

  • Vaccination certificate 
    • Accepted vaccines: BioNTech/Pfizer / Moderna / AstraZeneca (Vaxzevria) / Johnson&Johnson (Janssen)
    • In case of 2 doses
      • from the day of the 2nd dose
      • or from the 14th day after the 1st dose in case of recovery within 6 months of an infection
    • 2 doses - Janssen + mRNA
      • from the 14th day after the 1st dose
      • or from the day of the 2nd dose
    • 3 doses "booster" vaccination
      • from the day of the 2nd dose
      • or from the day of the 3rd dose
    • In case of 1 dose, from the 14th day after the vaccination
  • Negative COVID-19 test certificate
    • PCR test, valid for 72 hours
    • Certified rapid antigen test, valid for 48 hours
  • Recovery certificate
    • The recovery certificate is valid between the 11th and 180th day after the date of the result of the positive PCR test.

How the application works

  • Open the application
  • Scan the QR code of a CovidCheck certificate that is on paper or on a digital device (smartphone, tablet)
  • The validity result appears:
    • Green: authentic and valid certificate
    • Red: non-authentic or invalid certificate

It is also possible to check the validity of your CovidCheck certificate against the rules of another country: Scan the QR code, then click on the button below the flag displayed at the top of the result screen and select the respective country.

Update of the application and the database

To ensure that national and European (EU DCC) certificates are correctly read by the CovidCheck.lu application, please:

  • regularly check that you have the latest version of the application installed (via the Apple App Store and the Google Play Store)
  • in case of problems, daily synchronise the application with the national backend, which contains all technical data of the EU Member States. This data is needed to verify the authenticity and validity of the European EU DCC certificates. To do this, connect your device to the Internet, open the application, click on "Settings" at the bottom and then on "Synchronise with the National Backend".

FAQ

Who can install the App?

The app is freely available on the Apple App Store and Google Play Store. 

When do I need the App?

You only need to install it if you need to check the authenticity and validity of a certificate. 

I need to present a valid certificate. Do I need the App?

No, you do not need the App. All you need is your certificate in paper or digital form (e.g. PDF). The app is only intended to check the authenticity and validity of a certificate. 

Do I need an Internet connection (mobile or Wi-Fi) to use CovidCheck.lu?

You need an Internet connection to download and install the App. The App does not need an Internet connection to verify the authenticity of a certificate.

The App must have regular access to the Internet to download cryptographic keys from other countries. 

Do I have to install the App updates when they are suggested?

Yes, it is important to install all updates because they may contain new features or changes to national rules.

What are the requirements for installing the app?

To access and use the application, the user must have:

  • a compatible multimedia device, namely:
    • a mobile phone with a camera and the operating system iOS 13.0 or Android 5.0 or any later version
    • or a tablet with a camera and the operating system iOS 13.0 or Android 5.0 or any later version
  • a customer account on one of the Apple App Store or Google Play Store platforms
  • access to the Internet

Last update